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LDTC - Toolbox 
Burgel R.M. Levy 
 
Preliminaries: 
1. Toolbox can be freely downloaded at http://www.sil.org/computing/toolbox/downloads.htm 
2. download Toolbox to a folder in C://Program Files 
3. install Toolbox 
 
Setting up a Project: 
It generally makes sense to have one project for each language you are working on. A project may contain the 
following things: a dictionary (and a dictionary database file), one or more texts linked to the dictionary (and a 
text database file), and language encodings. 
1. open Toolbox 
2. click on Project > New 
3. when asked “To start a new project, you need to install the required files. Do you want to do that?”, click 

“Yes” and follow the instructions: 
4. go to Start > Programs > Toolbox > Start New Project 
5. follow the Wizard instructions 
6. go to the Desktop and open the new Project 
7. You will see an open file for texts, and two versions of the same dictionary. These files are located in 

C:\Toolbox. 
8. Close the Texts.txt file. We will not work with it today. Also close the Dictionary.txt: 2 file. 
 
Dictionary:  
The Dictionary comes with some preset settings. For example, you already have the following fields: 
 
\lx Lexeme  for the word in your language 
\ps Part of speech  for part of speech information (noun, verb, adjective, etc.) 
\ge Gloss (E)  for the gloss in English 
\dt Date (last edited)  for the date at which you last edited this data. 
 
1. enter your word after the \lx field 
2. enter part of speech info 
3. enter the English gloss 
4. to enter a new word, click Ctrl+N 
 
If you need other fields, you can enter them also. For example, if you want a tri-lingual dictionary, add a field 
for \gn (gloss national). Make sure you use the field markers from MDF. To check for field markers you can 
use, do the following: 
1. go to Project > Database Types 
2. make sure MDF 4.0 is selected 
3. click on Modify 
4. you will see a list of markers 
 
To make sure that all further entries will have your new fields, go to 
Database > Template 
click on OK 
now click on Ctrl+N 
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Setting up Fonts: 
You can use a number of different fonts in Toolbox.  
1. right-click on the field for which you want to change the font 
2. in the window that opens, click on Language Properties 
3. click on the Options tab 
4. click on Choose Font 
5. choose your font type 
 
If you want to use and input IPA directly: 
1. go to Project > Language Encodings 
2. click on Add… 
3. go to the Options tab, give it a Language Name (e.g. IPA) 
4. click on OK 
5. click on Close 
6. go to C:\Toolbox, open the Settings Folder 
7. right-click on the file “IPA” 
8. Open with Notebook 
9. delete everything in it 
10. find the file “vernacular” in the same folder 
11. open it with Notebook 
12. copy everything in it into the “IPA” file 
13. close the “vernacular” file 
14. go to the very bottom of the “IPA” file 
15. find “\kbdKeyman IPA93 1.0 (FF)” and delete it 
16. find the symbols you are going to need in the file above, and copy them (one under the other)  between the 

KeyDefs markers: 
 
\+KeyDefs  
your  
symbols 
go  
here 
\-KeyDefs 
 
17. next, in front of the symbols, put the characters you will use to type these symbols. I recommend using 

capital letters, or letters you are sure you won’t need for your language. The key letter needs to be separated 
from the symbol by a space. Like this: 

 
\+KeyDefs  
q æ 
N ŋ 
C ɕ 
 
18. save “IPA” and close it 
19. go back to Toolbox 
20. go to Projects > Language Encodings, find IPA, select it, and click on Modify 
21. go to the Options tab, and check “Use internal keyboard” 
22. click on OK and then on Close 
23. right-click on the \lx field marker in the Dictionary 
24. change “Language Encoding” to IPA, and click on OK 
25. you should now be able to type IPA into your Lexeme field 
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LDTC - Advanced Workshops 
Toolbox 
Burgel R.M. Levy 
 
Preliminaries: 
4. Toolbox can be freely downloaded at http://www.sil.org/computing/toolbox/downloads.htm 
5. download Toolbox to a folder in C://Program Files 
6. install Toolbox 
 
Setting up a Project: 
It generally makes sense to have one project for each language you are working on. A project may contain the 
following things: a dictionary (and a dictionary database file), one or more texts linked to the dictionary (and a 
text database file), language encodings. 
9. open Toolbox 
10. click on Project > New 
11. when asked “To start a new project, you need to install the required files. Do you want to do that?”, click 

“No” (this is an easy way to set up a new project, but it only works when you are an administrator on the 
computer you are working on) 

12. in the window that opens, navigate to the folder where you wan to save your Toolbox materials (for this 
exercise, the LDTC Toolbox folder on the Desktop) 

13. type “Project1” in the File name field, make sure File Type is “Project Files (*.prj)”, and click “Save” 
14. your project name should appear in the bottom bar of the Toolbox window. 
 
Setting up a Dictionary database type: 
A dictionary is a database type. Other possible database types are texts, metadata collections, etc. You have to 
tell Toolbox what kind of database type you are making, and what the properties of that database type are going 
to be. Here is how to do that: 
1. go to Project > Database Types 
2. in the Database Types window, click on “Add” 
3. as the Name for this database type, write “dictionary” (replace “added”) 
4. as the Record Marker, write “lx” 
5. click OK 
6. go to the Markers tab (here is where you will tell Toolbox what kind of information will be in your database 

type, and how to mark each unit of information) 
7. select \lx 
8. click on Modify 
9. in the “Field Name” field, enter “Lexeme” 
10. click OK 
11. in addition to \lx, we are going to set up the following markers: 

a) ps (part of speech) 
b) ge (Gloss English) 

12. to add a marker, click on Add 
13. enter the marker (two letters) 
14. enter the full name of the field in the “Field Name” field 
15. click OK 
 
16. when you have added all three markers, click OK 
17. click Close 
 
(Of course you can set up many more markers. To see a list of possible markers, go to Project > Database Types, 
and look at MDF 4.0.) 
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Setting up Fonts: 
You can use a number of different fonts in Toolbox. We are going to set up IPA to use for the lexeme field. 
1. go to Project > Language Encodings 
2. the Default language encoding is already there. It is the regular Latin font with the US keyboard. 
3. click on Add and then on Modify 
4. in the “Name” field, replace “added” with “IPA” 
5. click OK 
6. select the “Options” tab 
7. in the “Language Name” field, write “IPA” 
8. in the “Description” field, write “International Phonetic Alphabet” (or whatever makes sense to you) 
9. make sure that “US” is selected as the “Keyboard” 
10. make sure that “Use internal keyboard” is checked 
11. click “Choose Font” 
12. in the Font menu, select an IPA font (Arial Unicode MS, Charis SIL, Doulos SIL, etc.) 
13. in the Font Style menu, select “bold” 
14. in the Size menu, select 12 
15. click OK 
16. click OK again to close the Language Encoding Properties window 
17. click Close to close Language Encodings 
18. (eventually you also need to set up Case and Punctuation, as well as Variables. If you need help with that, 

let me know) 
 
19. click on File > New 
1. make sure you are in the Toolbox folder on the Desktop 
2. write “Dictionary1” in the File name box 
3. click Save 
4. in the “Select Database Type” window, make sure that “dictionary” is selected 
5. click OK 
6. the first dictionary entry window will open 
7. right-click on the line with \lx 
8. make sure that “IPA” is selected as the “Language Encoding” 
9. click OK 
10. close Toolbox 
 
Making a dictionary: 
We will now make a small dictionary 
1. open your Project1 (double click on Project1 in the Toolbox folder on the Desktop) 
2. your dictionary should open automatically (if it doesn’t open it through File > Open) 
3. your courser should be right after the \lx marker 
4. type your first word: kæt (‘cat’). Refer to your Fonts document for keyboard mappings 
5. hit Enter 
6. click the backslash key (“\”): a drop-down menu should open, containing the field markers we set up earlier 
7. select \ps (part of speech) and hit Return 
8. enter n. (for noun) 
9. hit Return, type backslash, and select \ge (gloss English), and type “cat” 
 
10. So we don’t have to select field markers in the future, we are going to save this set-up as a template 
11. click on Database > Template. When you see the message “The record template will be set to the fields in 

the current record”, click OK. 
12. let’s add some more words: 
13. click on Database > Insert Record (or Ctrl + N) 
14. in the window that opens, enter the next word: drɪŋk (‘drink’) and click OK 
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15. Toolbox will create a new dictionary entry, with the field markers (\ps and \ge) already there 
16. enter v. for part of speech, and “drink” for gloss English 
17. insert another dictionary entry for mɪlk, n., “milk” 
18. insert another dictionary entry -s, part of speech n.s. (nominal suffix), gloss English “plural” 
19. save your work frequently by clicking on Ctrl+S 
This is our complete dictionary for now. 
 
Adding Another Language: 
If you need another language, e.g. Chinese, Japanese, or Spanish, you need to set it up before you can make the 
dictionary. You can use any language that is set up on your computer. 
1. go to Project > Language Encodings 
2. click on Add 
3. go to Options 
4. change the Language Name 
5. change the keyboard (all keyboards which are installed on your computer should appear in the drop-down 

menu) 
6. click on Choose Fonts and select the proper font. For example, if you are setting up Chinese and are 

working with Microsoft Word on your computer, you should select “PMingLiU”. 
7. click on OK, OK, and Close 
8. right-click on the field marker for the field in which you want to use this language (e.g. \gn for Gloss 

National) 
9. change the language in the Language Encoding menu 
10. click on OK 
11. you should now be able to type your language in this field (but only in this field) in every entry 
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Interlinearization 
 
Setting up a text: 
Next we are going to set up a text, so that we can try out the interlinearization function of Toolbox. In order to 
do that, we need to set up a database type “text”, in addition to our database type “dictionary”. 
1. go to Project > Database Types 
2. in the Database Types window, click on “Add” 
3. as the Name for this database type, write “text” 
4. as the Record Marker, write “id” 
5. click OK 
6. go to the Markers tab (here is where you will tell Toolbox what kind of information will be in your 

database type, and how to mark each unit of information) 
7. select \id 
8. click on Modify 
9. in the “Field Name” field, enter “texts” 
10. click OK 
11. we are going to set up the following other markers: 

a) ref (Reference Number: unique reference for each sentence) 
b) txt (text: here is where the actual text goes), Language Encoding = IPA 
c) mb (morpheme breaks: this is the line for glosses), Language Encoding = IPA 
d) ps (part of speech) 
e) ge (English gloss for each morpheme) 
f) ft (free translation) 

12. to add a marker, click on Add 
13. enter the marker (two letters) 
14. enter the full name of the field in the “Field Name” field 
15. click OK  
16. after you have entered all field markers, click OK (to close the Database Type Properties: text 

window) 
17. click Close (to close the Database Types window) 
 
Now are going enter some actual text: 
18. click File > New 
19. write a file name in the File Name box, e.g. “Text1” 
20. click Save 
21. in the Select Database Type window, select “text” from the drop-down menu and click OK 
22. the text document will open, with the courser next to \id 
23. write “Sentences” 
24. click Enter click \ 
25. select \ref 
26. enter a reference number (“sentence001”) 
27. click Enter 
28. click \ 
29. select \txt from the drop-down menu 
30. write: kæts ɔlweiz drɪŋk mɪlk (since you selected IPA as the language encoding, you can use the 

same keyboard shortcuts as in the dictionary. Refer to the Fonts document.) 
31. click Ctrl+S to save your text 
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Setting up Interlinearization: 
In order to be able to interlinearize (gloss) your text, you have to link your text with you dictionary. 
Basically, you have to tell Toolbox where to look for translations of morphemes when it processes 
your text, and how to map morphemes to glosses and parts of speech. 
1. click on Project > Database Types and select “text” 
2. click on Modify 
3. select the Interlinear tab 
 
4. click on Add… 
5. select Parse and click OK 
6. in the From Marker field, select “txt Text” 
7. in the To Marker field, select “mb Morpheme Break” 
8. for “If parse fails”, add a check mark for “Insert into Lexicon” 
9. click the Lexicon button 
10. select “Dictionary1” in the Available Databases field, and click Insert. Dictionary1 should move to 

the Databases to Search field. 
11. in the Available Markers field select “lx” and click Insert. “lx” should move to the Markers to Find 

field. 
12. in the Marker to Output field, select “lx Lexeme” 
13. click OK 
14. click OK to close the Parse window 
 
15. click on Add, select “Lookup” and click OK 
16. choose “mb” as the From Marker, and “ge” as the To Marker 
17. click on the Lexicon button 
18. insert “Dictionary1” as the Database to Search 
19. choose “lx” as the Marker to Find and “ge” the Marker to Output 
20. click OK 
21. click OK to close the Lookup window 
 
22. click Add, select Lookup, and click OK 
23. select “mb” as the From Marker, and “ps” as the To Marker 
24. click on the Lexicon button 
25. select “dictionary1” as the Database to Search 
26. select “lx” as the Marker to Find, and “ps” as the Marker to Output 
27. click OK 
28. click OK to close the Lookup window 
 
We also have to set up a Jump Path to the Dictionary1, for inserting new words into the dictionary 
when they appear in the text. 
 
29. select the Jump Path tab 
30. click Add… 
31. write “JP1” as Jump Path name 
32. select txt as the “Fields to Jump from” 
33. insert Dictionary1 as the Jump Path Destination 
34. click OK 
 
35. click OK again to close the Database Type Properties: text window 
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36. click Close to close the Database Types window 
 
Interlinearize a text: 
1. go back to your text document in Toolbox 
2. click your courser into the \txt line 
3. click the interlinearize button (or Alt+I) 
4. the text will start to be interlinearized, but will stop at “always”, because this word is not in the 

lexicon. Your dictionary will open (if it was closed), and you will see a message window. 
5. when you see the Lookup Failure window (“Insert in lexicon?”), click Yes.  
6. enter ps and ge info into the lexicon 
7. go back to your text, place the courses in the beginning of the \txt line, and click the interlinearize 

button again 
8. the rest of the sentence will be done 
9. click Enter and “\” and select ft 
10. enter your free translation 
 
11. enter the next sentence of your text in the same document:  
12. click Enter and “\”, select \ref, write the reference number 
13. click Enter and “\”, select \txt, write your sentence 
14. interlinearize 
 
 
 


